Welcome to the Gamebase 64 forums.                 An attempt to document ALL Commodore 64 gameware before it's too late!

CCS64: "crazy" keyboard!

Are you having problems setting up GB64 on your machine? Ask your questions in here!

Moderator: Jimbo

User avatar
NK1
New Member
Location: Italy
Posts: 4
Joined: Sun Jan 20, 2019 9:46 am

CCS64: "crazy" keyboard!

Sun Jan 20, 2019 10:03 am

Hi boys,
I didn't find any topic about my problem.
I have many roms for Commodore 64 (tape, disk and screenshot files), but using them I've discovered that many games doesn't work well. The keys of my keyboard are crazy, because even if I don't touch any of them, CCS64's arrow (or character, or menu row) is moved. If I try to move in the opposite direction (or another one), usually I can't. Another problem is happened: my PC's Caps Lock is turned on anf off continuosly. I've tried to swap CCS64 port, to disable them, but usually it can't help.
I think it's a some games' problem, because other ones are ok. But do you know if I can solve this problems? It's so bad...

P.S. Sorry for my english but I'm italian...
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1881
Joined: Sun Jun 19, 2005 3:30 pm

Re: CCS64: "crazy" keyboard!

Sun Jan 20, 2019 11:29 am

sounds like a problem with the Joystick (analogue) calibration.
or the joystick settings are incorrectly trying to use a Paddle controller.
So your mouse could be triggering the movement.
try deleting the ccs64.cfg file, and creating a new one.

If you click into the emulator window while playing a game, that can mess things up sometimes.
especially if you map Ctrl or Alt as a fire button.
Had very similar effects with other emulators.

no idea why your caps lock is flashing on/off constantly.
unless you mapped the fire button as caps lock, and auto fire is on.
but more like a keyboard driver issue than a ccs64 bug.
User avatar
NK1
New Member
Location: Italy
Posts: 4
Joined: Sun Jan 20, 2019 9:46 am

Re: CCS64: "crazy" keyboard!

Sun Jan 20, 2019 7:48 pm

First, thank you very much .mad.

1 - I've forgotten to say that I don't use a real Joystick, but I I've read in CCS64 instructions to set joystick + key set 1, configuring every direction and buttons as keys of my PC keyboard (I've made UP:W DOWN:S LEFT:A RIGHT:D FIRE:P FIRE 2:O FIRE 3:I).
2 - I've tried to calibrate my joystick, but using a keyboard it seems impossible to me... I didn't use my mouse, I've tried but something's go wrong during configuration because it wasn't work.
3 - Ok, I'll try to re-configure anything, hoping it could be the right solution.
4 - Ok, I won't touch emulator windows. It's a promise! ahahahah. But I've setted P as fire.
5 - Wait, I've understood the problem's on Scroll Lock key! And in my laptop you can lock scrolling using Function key and F12! It could be help to know why it flashes? It's a strange thing, because it isn't a key pressed but two...
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1881
Joined: Sun Jun 19, 2005 3:30 pm

Re: CCS64: "crazy" keyboard!

Mon Jan 21, 2019 11:12 am

In CCS64 the scroll lock LED can be set to show the disk drive activity - mimic a real 1541 LED.
So the flashing is normal, it just means the game is loading, and nothing to worry about.

you can turn it off in the "Special" options.
or by editing the config file $KEYLED1541ENABLE=0

c64.cfg

Code: Select all

$SYSTEMMODE=0
$SCREENMODE=0
$SCREENROTATE=0
$SCREENFILTER=0
$REFRESHRATE=0
$REFRESHCUSTOM=50
$UPDATEMODE=0
$SKIPFRAMES=0
$SYNCRATE=0
$SOUNDENABLE=YES
$SIDFILTERENABLE=YES
$SOUNDMODE=3
$SAMPLEFREQ=44100
$SAMPLEBITS=16
$OVERSAMPLE=1
$LOADPATH=C:\GameBase\GBC_v15\emulators\CCS64 V3.9.2 Offical\
$ROMPATH=C:\GameBase\GBC_v15\emulators\CCS64 V3.9.2 Offical\
$CONTROLPORT1=0
$CONTROLPORT2=1
$CONTROLPORT1MODE=1
$CONTROLPORT2MODE=17
$RGBCOLOR0=191d19
$RGBCOLOR1=fcf9fc
$RGBCOLOR2=933a4c
$RGBCOLOR3=b6fafa
$RGBCOLOR4=d27ded
$RGBCOLOR5=6acf6f
$RGBCOLOR6=4f44d8
$RGBCOLOR7=fbfb8b
$RGBCOLOR8=d89c5b
$RGBCOLOR9=7f5307
$RGBCOLOR10=ef839f
$RGBCOLOR11=575753
$RGBCOLOR12=a3a7a7
$RGBCOLOR13=b7fbbf
$RGBCOLOR14=a397ff
$RGBCOLOR15=efe9e7
$COLORBRIGHTNESS=0
$COLORCONTRAST=100
$COLORSATURATION=100
$COLORGAMMA=100
$JOYKEY0_0=309
$JOYKEY0_1=76
$JOYKEY0_2=71
$JOYKEY0_3=73
$JOYKEY0_4=-1
$JOYKEY0_5=-1
$JOYKEY0_6=-1
$JOYKEY0_7=-1
$JOYKEY0_8=312
$JOYKEY0_9=-1
$JOYKEY0_10=-1
$JOYKEY1_0=72
$JOYKEY1_1=80
$JOYKEY1_2=75
$JOYKEY1_3=77
$JOYKEY1_4=-1
$JOYKEY1_5=-1
$JOYKEY1_6=-1
$JOYKEY1_7=-1
$JOYKEY1_8=285
$JOYKEY1_9=-1
$JOYKEY1_10=-1
$JOYKEY2_0=328
$JOYKEY2_1=336
$JOYKEY2_2=331
$JOYKEY2_3=333
$JOYKEY2_4=-1
$JOYKEY2_5=-1
$JOYKEY2_6=-1
$JOYKEY2_7=-1
$JOYKEY2_8=285
$JOYKEY2_9=-1
$JOYKEY2_10=-1
$CARTENABLE=NO
$CARTPATH=C:\GameBase\GBC_v15\emulators\CCS64 V3.9.2 Offical\
$CARTLOAD=
$REUENABLE=NO
$REUSIZE=2
$DISKSAVEMODE=1
$NR1541DRIVES=1
$MAX1541SPEED=0
$KEYLED1541ENABLE=0
$RESETMEMORYPATTERN=0
$MENUCOLOR0=6
$MENUCOLOR1=14
$MENUCOLOR2=12
$MENUCOLOR3=1
$MENUCOLOR4=10
$MENUCOLOR5=11
$STATEPATH=C:\GameBase\GBC_v15\emulators\CCS64 V3.9.2 Offical\
$REUFILEENABLE=NO
$SIDVERSION=0
$SIDPARFGAIN=100
$SIDPARFBASE=100
$SIDPARDGAIN=100
$SIDPARDBASE=100
$HARDSIDDEVICE=-1
$HARDSIDMODE=0
$PALETTEMODE=0
$PALSATURATION=1000
$PALBRIGHTNESS=0
$PALCONTRAST=1000
$PALGAMMA=1136
$SCREENSHOTSTARTX=0
$SCREENSHOTSTOPX=0
$SCREENSHOTSTARTY=0
$SCREENSHOTSTOPY=0
$C2NNOISEENABLE=1
$KEYMAP0001=77
$KEYMAP0002=70
$KEYMAP0003=73
$KEYMAP0004=10
$KEYMAP0005=13
$KEYMAP0006=20
$KEYMAP0007=23
$KEYMAP0008=30
$KEYMAP0009=33
$KEYMAP000a=40
$KEYMAP000b=43
$KEYMAP000c=50
$KEYMAP000d=53
$KEYMAP000e=00
$KEYMAP000f=72
$KEYMAP0010=76
$KEYMAP0011=11
$KEYMAP0012=16
$KEYMAP0013=21
$KEYMAP0014=26
$KEYMAP0015=31
$KEYMAP0016=36
$KEYMAP0017=41
$KEYMAP0018=46
$KEYMAP0019=51
$KEYMAP001a=56
$KEYMAP001b=61
$KEYMAP001c=01
$KEYMAP001d=75
$KEYMAP001e=12
$KEYMAP001f=15
$KEYMAP0020=22
$KEYMAP0021=25
$KEYMAP0022=32
$KEYMAP0023=35
$KEYMAP0024=42
$KEYMAP0025=45
$KEYMAP0026=52
$KEYMAP0027=55
$KEYMAP0028=62
$KEYMAP0029=71
$KEYMAP002a=17
$KEYMAP002b=65
$KEYMAP002c=14
$KEYMAP002d=27
$KEYMAP002e=24
$KEYMAP002f=37
$KEYMAP0030=34
$KEYMAP0031=47
$KEYMAP0032=44
$KEYMAP0033=57
$KEYMAP0034=54
$KEYMAP0035=67
$KEYMAP0036=64
$KEYMAP0039=74
$KEYMAP003b=04
$KEYMAP003c=0c
$KEYMAP003d=05
$KEYMAP003e=0d
$KEYMAP003f=06
$KEYMAP0040=0e
$KEYMAP0041=03
$KEYMAP0042=0b
$KEYMAP0147=63
$KEYMAP0148=0f
$KEYMAP014b=0a
$KEYMAP014d=02
$KEYMAP014f=61
$KEYMAP0150=07
$KEYMAP0152=60
$KEYMAP0153=66
$WINDOWSIZEX=384
$WINDOWSIZEY=282
$LANGUAGE=0
$JOYDETECTENABLE=NO
$SHIFTKEYAUTO=RIGHT
Setting the Joystick movement keys to the main keyboard is not reccomended.
as most games use the keyboard for something or other.
Navigating menus etc.
Depending how well the emulator is coded, the movement key coluld be mapped twice in some instances (joystick / c64 keypress). Which could be the root of your problem.

best to Avoid these C64 keys when mapping a joystick.
Ctrl = Commodore Key
ESC & TAB = Run/Stop
PC Cursor Keys = C64 Cursors (used a lot in games)
SHIFT
PageUp - Restore

I know it's harder to control, but remap everything on NumPad 2,4,6,8.
and see if that fixes the problem.

and only map 1 button for fire not 3.
User avatar
NK1
New Member
Location: Italy
Posts: 4
Joined: Sun Jan 20, 2019 9:46 am

Re: CCS64: "crazy" keyboard!

Mon Jan 21, 2019 11:14 pm

Hallo,
thank you again .mad.
Well, if it was only a LED I liked it, but in my laptop anytime a block key is pressed, a padlock design compares in my screen... Now I've fixed it, thanks.
Now...
I have followed your advices, as you can see
pic 1.PNG
keys
pic 1.PNG (11.97 KiB) Viewed 9612 times
but my problem's not solved...
Look as I've setted inputs, if it's ok, please
pic 2.PNG
set
pic 2.PNG (10.94 KiB) Viewed 9612 times
because I didn't understand how to map twice...
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1881
Joined: Sun Jun 19, 2005 3:30 pm

Re: CCS64: "crazy" keyboard!

Tue Jan 22, 2019 12:26 pm

your config looks ok to me.
most joystick games use port#2 as player#1 default.
so if you have zero control, press Alt+F10 during a game to switch between port 1-2.

If the control is still "crazy" then it could be something else interfering with the keyboard.
Are you using Win10?. :P
maybe the problem is Win10 just doesn't like the CCS64 code, with a Direct X driver not being compatible.

or you have accessibilty functions turned on (sticky keys).
press SHIFT five times - Turn Sticky Keys on or off
Num Lock for five seconds - Turn Toggle Keys on or off

failing that, i can only suggest you try WinVICE.
I am pretty sure that will work for you.
http://vice-emu.sourceforge.net/windows.html
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1881
Joined: Sun Jun 19, 2005 3:30 pm

Re: CCS64: "crazy" keyboard!

Wed Jan 23, 2019 6:21 pm

just found this link over on Lemon.
posted by K.C. 8)

CCS64 Re-compiled using Visual Studio 2015.
should fix a few problems running on Win10.
http://www.ccs64.com/CCS64-2015.zip
User avatar
NK1
New Member
Location: Italy
Posts: 4
Joined: Sun Jan 20, 2019 9:46 am

Re: CCS64: "crazy" keyboard!

Tue Jan 29, 2019 11:46 am

Hi .mad.,
I've downloaded that version, but even if it solves some key problems, it often stucks the game.
But now I'm using VICE to play those games with keys problems, and everything's right! Thanks!

Return to “GB64 Help!”

Who is online

Users browsing this forum: No registered users and 1 guest