Page 1 of 1


Posted: Sun Nov 11, 2007 4:24 pm
by .mad.
Maybe this is a Windows Language Install problem??

I have been working on a TRDOS GameBase for quite a while, and i am wondering if it is possible to have the Russian Language displayed in the GameBase frontend.

or do i need to start translating all the game names.

any ideas welcome!

Posted: Mon Nov 12, 2007 10:13 am
by hillelr
i think its better to have the game in english
in worldofspectrum website all the titles are also in english.[/img]

Posted: Mon Nov 12, 2007 3:20 pm
by .mad.
thanks for the reply. :o

maybe the translation is the way to go.
i was thinking of company names or hackers that might not translate to English that well. :?

Posted: Sat May 03, 2008 2:37 pm
by JohnCKirk
I assume that you're talking about the Cyrillic alphabet? The short answer is that you can't use it in the current version of GameBase, but I'll hopefully be able to fix that in the new version.

The longer answer involves the way that letters are actually stored inside a computer. Basically, each letter has a corresponding number, e.g. "A" is 65, "B" is 66, ... , "Z" is 90, then "a" is 97, ... , "z" is 122. That's fine for the English alphabet, along with digits and punctuation marks, because they all fit into the range 0-127. This is called the ASCII character set.

On a "normal" (European/American) computer, each character is stored in 1 byte, so it can be any number between 0 and 255. The first half of this (0-127) is always the same, but the second half (128-255) varies between countries. For instance, a Greek computer will use the second half of the range for Greek letters, whereas a Russian computer will use the second half for Russian (Cyrillic) letters. So, if you save a document with these extra letters, you need to make sure that you open it on the same type of computer, otherwise it will look pretty weird (e.g. all your Russian letters will turn into Greek letters).

When you have to store Chinese/Japanese/Korean letters, it gets even harder: they have too many "letters" to fit into one byte, so they use MBCS (Multiple Byte Character Set). Again, you have to make sure that your computer is set up the same way, i.e. that you've selected the same language in Windows, otherwise you just see something like "?????".

The solution to all of this is Unicode: there's one huge list of letters, which covers every language in the world. So, you can save your document on any computer, open it on any other computer, and everything will look the same.

Well, when I say "any" computer, I mean that your computer can be set up for any particular language, but it does need to support Unicode, and this is where it gets tricky. In particular, Windows 98 only has limited support for Unicode, VB6 is a bit iffy, and Access 97 doesn't support it at all. Access 2000 does, but that means that the GameBase databases will need to be converted into a new format. I only have Office 2007 on my machine, and this format definitely isn't compatible with the current version of GameBase; if anyone has an "in between" version of Access then you could try to convert a database and see whether it works.

Once the database issues are sorted out, it's fairly easy to actually enter the Cyrillic letters. Go to the "Character Map" utility in Windows, choose the option for "Group by Unicode subrange", choose Cyrillic in the new window that pops up, then you can select the relevant letters and copy them across.

I'm actually simplifying this (believe it or not!), because it's a pretty complicated subject, but hopefully this makes some sense.


Posted: Sun May 04, 2008 11:00 am
by .mad.
Spasiba. :lol:

that's just what i needed to know. 8)

Posted: Mon Mar 30, 2009 10:57 pm
by JohnCKirk
Following up on this, I can confirm that the current version of GameBase is compatible with Access 2000. The C264 database is already in that format, and I've converted the other databases (e.g. GBC_v05) and they work fine too.

I used Character Map to select some Cyrillic characters, then copy them into the database. In Access they look fine ("1st Division ManagerАЖфщйп"), but in GameBase they just show up as question marks ("1st Division Manager??????"). If I try editing the title in GameBase, by pasting the same text into the dialog box, it shows up as "1st Division ManagerÀÆôùéï".

I've also tested this with GameBase.NET (still a work in progress), and it works fine there, i.e. you can see the Cyrillic characters in the front-end.

Posted: Tue Mar 31, 2009 10:45 am
by .mad.
thank's for the update,

i had already got the same results as you.

Gamebase.NET sounds exciting. :D
please let me know when any beta versions are available. :wink: