Page 1 of 1

Problem getting Saint 212 to run..

Posted: Sun Nov 23, 2008 6:34 pm
by Paul Irvine
Every time I try to play a game it comes up

game type not supported by this emulator (.zip)

Now I've tried using the settings for Saint 1.6 as they came but that gives the same error.

Even steem throws up the error?

Any idea's, the script files are unaltered 3.1d ones so I can't see what the issue is. I've tried adding ;ZIP into the types it can read on the emulator setup page.

Nothing seems to work..


Posted: Mon Nov 24, 2008 8:16 pm
by .mad.
Hi Paul,

this contains a sample script and emulator.ini for you to try.
adding ZIP to the ini will only mess it up.
the disk image will not unzip when this file type is added.

this should also work with the "emulator setup wizard".

Good Luck. :wink:

Posted: Tue Nov 25, 2008 2:33 pm
by Paul Irvine
Thanks .Mad..

Will have a try a little later and let you know..

Many thanks

Posted: Tue Nov 25, 2008 4:07 pm
by Paul Irvine
Something weird is going on, I've tried reinstalling GB1.2, resetting the 3.1d setup from scratch, cleaning out all the dirs so that it's totally the basic as it was meant to be 3.1d install.

The best I can get 2.12 or 1.61 Saint to do is give an error saying a referenced script file is missing (presuming Gamebase.ini) which IS there next to where the Gemu's is pointing to the emulator exe and then saint starts to run but appears to not have a disk installed because after a few drive checks it goes to the desktop.

Now Steem IS working properly so I'm guessing it's down to Saint as opposed to the setup.

Trouble is, I can't remember if Saint ever worked on it?

Any idea's .Mad

used your scripts etc

What's odd is I feel like it's not picking up images from locations ie it might be running in it's Saint dir but it's looking for other files in other places.

The reason I say this is that I found a SaintDefault.rom residing in my D:\ root, Games is on my D:\ drive in the Gamebase folder but why it put a rom there I don't know?


Posted: Tue Nov 25, 2008 5:48 pm
by .mad.
hi Paul,

this one works for me.
restored all the ini files back to default.

this is setup to be run in...
c:\program files\gamebase\GBST v3.1d\

first run "SainT.exe"
setup your config and TOS.ROM and save it.

at least you got it working with one emulator, so there's no panic.

Posted: Wed Nov 26, 2008 5:28 pm
by Paul Irvine
Phew...What a long day..

Nothing was working...

Decided to go and get the entire 3.1d setup again (was missing a few games anyway). After hours of unpacking and setting up it only went and worked!

2.12 is now (fingers crossed working nicely thank you..

Ta for all your time and work .Mad...

Put a few more coals on the old fire up there :)

A Saint Script File

Posted: Sun May 17, 2009 10:29 am
by Emulation Freak

Here below a copy the saint script I use with gamebasest.
I presently using v2.13.

;* *
;* Script file for running SainT Emulator. *
;* *

; Emulator File: SAINT.EXE
; Associated File: saint.ini (use the one in SainT folder
; due to bug with saint not accepting ini files from other folders).
; Use Short Filenames: NO
; File Types: ST;MSA;STX

;* To play STX file please download 'pasti.dll' from saint
;* home page.
;* Then put pasti.dll into saint directory.

If GameType CONTAINS(st||msa||stx)

; Use default ini file in saint directory due to bug with saint emulator.
Add_CLP(-autorun saint.ini)

;Set Drive A to selected game image

;Check for Disk B if exists set Drive B
If NumGameFiles > 1
End If

; Check for Hard Disk Image. Quit if found as Saint does not support Hard disk images. ;
If Key_Harddisk CONTAINS(Yes)
Show_Message(Saint Emulator can not play Hard Games)
;Run the Emulator
End If

;invalid game file type
Show_Message(GAME_NOT_SUPPORTED%crlfx2%Supported types: ST, MSA, STX with pasti.dll)

End If