Page 1 of 1

Running Extras from GB

Posted: Tue Mar 03, 2015 4:14 pm
by davidmt
I am having difficulty running any of the games under "Extras" from the front-end (specifically games under "Disk", "Cart" and "Tapes" folders).

For example, running Ms. Pac-Man "original cartridge" launches my emulator (CCS64) but just opens a READY prompt on the C64. Launching the "Original Disk" shows a "PRESS PLAY ON TAPE".

I recall this was a problem a few versions ago, but thought it was fixed. If I run the files directly from the emulator, they all work, so I know its something with the front-end communicating to the emulator.

Is there a setting I am missing somewhere?
Thanks for any help! :)

Posted: Tue Mar 03, 2015 7:28 pm
by .mad.
It is a problem with one of your settings.
Sounds like you need to re-configure it.
delete your current .ini files.
download the latest emulators and scripts (included in the GBC_v13 installer).
Then run the Emulator setup wizard from GameBase v1.3.

Older versions of CCS64 will require the older script file.
You need CCS64 V3.9.1 Offical.

do you have the file c64.cfg in the CCS64 dir.

Code: Select all

check the emulators.ini for errors.
it should look like this in the CCS64 part.

Code: Select all

1=CCS64 v3.9.1

[CCS64 v3.9.1]
EmulatorPathFile=C:\GameBase\GBC_v13\Emulators\CCS64 V3.9.1 Offical\CCS64.exe
1=C:\GameBase\GBC_v13\Emulators\CCS64 V3.9.1 Offical\c64.cfg
Remove ZIP;RAR;7z if they are in the supported types.

have you edited the script in some way.

Are you using the latest version of GameBase (v1.3).
Uninstall v1.2 if you have it.

Have you changed the Gamebase rezip path.
Open gamebase and select tools frontend options, to check.

default is c:\gbgame\

that's enough guesses for you to try. :)

Posted: Wed Mar 04, 2015 1:26 am
by davidmt
Thank you for sharing your emulators.ini file, the problem turned out to be very simple:

[CCS64 v3.9.1]

Once I removed the "use short filenames" option, it worked perfectly. Appreciate the help!