Page 1 of 2

GB64 works but emu wont run...

Posted: Thu Jan 26, 2012 8:13 pm
by subzero1970
what am i doing wrong???

emu just closes straight away...

Posted: Thu Jan 26, 2012 8:39 pm
by Michael Plate
The first thing you are doing wrong is to post a proper description of the problem...

Posted: Thu Jan 26, 2012 8:45 pm
by subzero1970
i have....double click the game and the emu just pops open for a millisecond and closes

Posted: Thu Jan 26, 2012 10:26 pm
by Hidron
There are a lot of possible variables.

Which version of the Gamebase frontend do you have installed? -v1.3 is the current one
Which version of GB64 are you running?-v08 is current
Which emulator/version of it are you using?
Did you configure the emulator inside GB64? (Gemus/Emulator Setup Wizard)
-Which game are you trying to run? (could be an issue with the game)

The more information you give us, the more likely we are to be able to help you out.

Posted: Sun Jan 29, 2012 7:02 pm
by subzero1970
my GB64 is v1.3, my Gamebase frontend is GBC_V05

the emulator was already configured, and no games will run.

Posted: Sun Jan 29, 2012 9:02 pm
by Michael Plate
Why should anyone help you if you put no efforts in a proper description?

Posted: Wed Mar 28, 2012 9:14 pm
by subzero1970
i cant give a description really, i have amiga, speccy, vic20 gamebase and they all work fine, however when i run GB64 it loads ok but when i double click to play a game i get a small message 'waiting for emulator to close' and the emu flashes open then closes! However if i run the emulator OUTSIDE of plays fine!

Posted: Thu Mar 29, 2012 11:55 am
by .mad.
Could be a few things...
Your Script is corrupt.
VICE.INI file is missing from the emulator DIR.
Your Emulators.ini is pointing to wrong emulator location.

this could be easily fixed.

1) Put your emulators in the default location.

2) Edit your EMULATORS.INI file and check the paths for the emulator and VICE.INI file.

*If you do not have the Vice.ini file (the script needs it).
Run emulator, set your options and select save current settings from WinVICE menu.

3) DELETE your emulators.INI file and run the Emulator setup wizard from the GameBase menu, and browse to your emulator x64.EXE.

If you have problems, i will go through it step by step with you.

PM me.

Posted: Thu Mar 29, 2012 8:25 pm
by subzero1970
followed that to the letter, still no luck :(

Posted: Fri Mar 30, 2012 3:42 pm
by .mad.
just thought...

do you have "ZIP,"RAR","7z" in the SupportedTypes in your Emulators.ini.
if you do. REMOVE THEM.

it should look like this sample.

Code: Select all

1=WinVICE v2.3 (x86)
[WinVICE v2.3 (x86)]
if you post ALL your INI files, like the sample above.
and tell us your emulator version and install location.
maybe we can help.

the more info you can give, the better.

Do you have GameBase on another drive other than C:\ ??

Do you have several versions of the same emulator installed.

because if you followed the above post to the letter.
it would be working. :wink:

Posted: Fri Mar 30, 2012 6:48 pm
by subzero1970
tbh i think my gamebase folder is messed up! and my emulators.ini doesnt even have a c64 emulator listed!!!

gamebase is in D:\
emulator is in D:\WinVICE-2.0

heres what emulators.ini looks like:

3=Spectaculator 6


[Spectaculator 6]
EmulatorPathFile=D:\Emulator\spectrum\spectaculator 6.25\Spectaculator.exe
ScriptFile=Spectaculator V6.txt


Posted: Fri Mar 30, 2012 7:58 pm
by .mad.
well that explains everything.
no wonder it doesn't work. :D

i will create a working setup (with all the latest C64 emulators included) and upload it tomorrow.

you might want to download the version "8" torrents while your waiting. 8)

Posted: Sat Mar 31, 2012 9:28 am
by .mad.
Ok here is GBC_v08 already setup with emulators configured.

read the included text file.

Just extract to your Newly Installed GameBase folder.

Posted: Sat Mar 31, 2012 9:32 am
by subzero1970
those torrents as as slow as snails..!!

thanks for your help!

Posted: Sun Apr 01, 2012 11:04 am
by subzero1970
torrent completed but erm...i dont see any emulators anywhere...