Welcome to the Gamebase 64 forums.                 An attempt to document ALL Commodore 64 gameware before it's too late!

Loading ISO files

Discuss GameBase, the Universal Emulator Frontend!

Moderator: Jimbo

Flarp
Keen Member
Keen Member
Posts: 105
Joined: Tue Aug 10, 2004 1:43 pm

Loading ISO files

Thu Jun 21, 2012 10:36 pm

I am making a Game Base project for my wife with her favorite music/video DVDs in .iso format.. I use VLC as my video player/emulator in this case. and when I initially select the .iso file it slowly opens it and I can select the file I want to select as the main file to load from the Gamebase.. in this case it is .ifo files.. and that will setup everything to run as if she loaded it from the main DVD.. but my problem is that when she clicks on it from the Game Base list it takes forever for it to load and start playing the file.. is there anyway this could be sped up in Game base for the future?
User avatar
.mad.
Respected Member
Respected Member
Location: Lancashire
Posts: 1973
Joined: Sun Jun 19, 2005 3:30 pm

Fri Jun 22, 2012 2:16 pm

Sounds like the problem is with the unpacking (wait time) of the ISO file.
while the sub files are being copied to the GBTEMP folder.
Only way to speed that up is get a quad core computer. :wink:

The simplest way to speed it up is to have your .ifo files unzipped (not in ISO format) in a folder and run them directly from there.

Or a smarter way would be to mount the ISO in Daemons util.
which will take a few seconds to mount. Then select your runnable files from the virtual drive.

Code: Select all

Run_Program(C:\Program Files\DAEMON Tools Lite\DTLite.exe||-unmount_All||WAIT)
Run_Program(C:\Program Files\DAEMON Tools Lite\DTLite.exe||-mount 0, "%gamepathfile%"||WAIT)
If you have a version of Daemons Tools already installed and working with a virtual drive.
Change %dbpath% in this script to your Daemons installed location.
Flarp
Keen Member
Keen Member
Posts: 105
Joined: Tue Aug 10, 2004 1:43 pm

Fri Jun 22, 2012 10:13 pm

I actually have a quad core phenom II 945 AMD cpu ..and it was taking 3 minutes.. but I figured it out on my own I just use 7zip to unzip the .iso file then hooked up the .ifo file again in Game Base and it starts right away now. but thanks for the help anyway

Return to “The GameBase Frontend”

Who is online

Users browsing this forum: No registered users and 3 guests